$re = '/(?<=[^=\d])\d+(?:\p{Zs}|&\w+;)%/';
$str = 'some 50%
and 50 %
now 50 %
47 %
42 %
width=50%
this width=42 % shouldn\'t match
while a calculation such as result = 27 % may match.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);