import re
regex = re.compile(r"(?<=[^=\d])\d+(?:\p{Zs}|&\w+;)%")
test_str = ("some 50%\n"
"and 50 %\n"
"now 50 %\n"
"47 %\n"
"42 %\n"
"width=50%\n"
"this width=42 % shouldn't match\n"
"while a calculation such as result = 27 % may match.\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")