using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!="")(\b[\w]+:\/\/[\w-?&;#~=\.\/\@]+[\w\/])";
string input = @"http://zzz.xx <a href=""https://ok.ru/"">https://vk.com/</a> ryreuerureu ftp://ya.ru";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}