import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!=\")(\\b[\\w]+:\\/\\/[\\w-?&;#~=\\.\\/\\@]+[\\w\\/])";
final String string = "http://zzz.xx <a href=\"https://ok.ru/\">https://vk.com/</a> ryreuerureu ftp://ya.ru";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}