re = /(?<!=")(\b[\w]+:\/\/[\w-?&;#~=\.\/\@]+[\w\/])/i
str = 'http://zzz.xx <a href="https://ok.ru/">https://vk.com/</a> ryreuerureu ftp://ya.ru'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end