const regex = /(?<!=")(\b[\w]+:\/\/[\w-?&;#~=\.\/\@]+[\w\/])/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!=")(\\b[\\w]+:\\\/\\\/[\\w-?&;#~=\\.\\\/\\@]+[\\w\\\/])', 'gi')
const str = `http://zzz.xx <a href="https://ok.ru/">https://vk.com/</a> ryreuerureu ftp://ya.ru`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}