use strict;
my $str = '/token1/token2/token3';
my $regex = qr/(?!^)//mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";