use strict;
my $str = 'ftp://sub.domain
mailto:example@example.com
http://127.0.0.1/index.htm
https://user:password@s--ub.do_main.com/path%20/to/whatever.html?key1=value1&key2=value2#fragment';
my $regex = qr/(?:(?:ftp|https?):\/\/|mailto:)(?:\w+(?::\w+)?@)?(?:(?:[a-zA-Z\-][\w+-\.]*)|(?:[\d\.]+))(?:\/\w[\w\.\/%]+)?(?:\?(?:\w+=\w+(?:&\w+=\w+)+))?(?:#\w+)?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}