re = /(?:(?:ftp|https?):\/\/|mailto:)(?:\w+(?::\w+)?@)?(?:(?:[a-zA-Z\-][\w+-\.]*)|(?:[\d\.]+))(?:\/\w[\w\.\/%]+)?(?:\?(?:\w+=\w+(?:&\w+=\w+)+))?(?:#\w+)?/
str = 'ftp://sub.domain
mailto:example@example.com
http://127.0.0.1/index.htm
https://user:password@s--ub.do_main.com/path%20/to/whatever.html?key1=value1&key2=value2#fragment'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end