const regex = /(?<![.!])(["\']).*?\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![.!])(["\\\']).*?\\1', 'gm')
const str = `"Took 0 seconds"
This is some other content "Took 0 seconds" and some more content
Some more content "Took 1 seconds" and more content ""
!"took 0 seconds"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}