import re
regex = re.compile(r"(?<![.!])([\"\']).*?\1", flags=re.MULTILINE)
test_str = ("\"Took 0 seconds\"\n"
"This is some other content \"Took 0 seconds\" and some more content\n"
"Some more content \"Took 1 seconds\" and more content \"\"\n"
"!\"took 0 seconds\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")