#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\w+)\s?:\s?[\"|']?([^\"|'|\s]+)"
Local $sString = "something else +good -bad 'other stuff' ++'good stuff' -"bad stuff" ---"dall'orto" a v ac filetype:pdf and AND path:temp\app test:"lkalksdf\lkjasldfkjjlkasfdlkjasdf" inv:test okl: lkjasdf asdfs : sei " & @CRLF & _
"file:'test' testing : aslfkdj " & @CRLF & _
""(\w+)\s?:\s?([^\s]+)" " & @CRLF & _
"(\w+)\s?:\s?([^\s]+)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")