// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(\w+)\s?:\s?[\"|']?([^\"|'|\s]+)"#).unwrap();
let string = "something else +good -bad 'other stuff' ++'good stuff' -\"bad stuff\" ---\"dall'orto\" a v ac filetype:pdf and AND path:temp\\app test:\"lkalksdf\\lkjasldfkjjlkasfdlkjasdf\" inv:test okl: lkjasdf asdfs : sei
file:'test' testing : aslfkdj
\"(\\w+)\\s?:\\s?([^\\s]+)\"
(\\w+)\\s?:\\s?([^\\s]+)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}