import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)\\s?:\\s?[\\\"|']?([^\\\"|'|\\s]+)";
final String string = "something else +good -bad 'other stuff' ++'good stuff' -\"bad stuff\" ---\"dall'orto\" a v ac filetype:pdf and AND path:temp\\app test:\"lkalksdf\\lkjasldfkjjlkasfdlkjasdf\" inv:test okl: lkjasdf asdfs : sei \n"
+ "file:'test' testing : aslfkdj \n"
+ "\"(\\w+)\\s?:\\s?([^\\s]+)\" \n"
+ "(\\w+)\\s?:\\s?([^\\s]+)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}