package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+)\s?:\s?[\"|']?([^\"|'|\s]+)`)
var str = `something else +good -bad 'other stuff' ++'good stuff' -"bad stuff" ---"dall'orto" a v ac filetype:pdf and AND path:temp\app test:"lkalksdf\lkjasldfkjjlkasfdlkjasdf" inv:test okl: lkjasdf asdfs : sei
file:'test' testing : aslfkdj
"(\w+)\s?:\s?([^\s]+)"
(\w+)\s?:\s?([^\s]+)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}