# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\<title\>).+(?=\<\/title\>)"
test_str = ("<title>COVEMA</title>\n"
"<title>PALMERO</title>\n"
"<title>PLASTIFERRO</title>\n"
"<title>UOCRA</title>\n"
"<title>REPAS</title>\n"
"<title>BTU</title>\n"
"<title>PANEDILE</title>\n"
"<title>ELEPRINT</title>\n"
"<title>JOSÉ J. CHEDIACK</title>\n"
"<title>NIRO CONSTRUCCIONES</title>\n"
"<title>HELPORT</title>\n"
"<title>BISCAYNE</title>\n"
"<title>COARCO</title>\n"
"<title>ESUCO</title>\n"
"<title>CPC</title>\n"
"<title>TEL 3</title>\n"
"<title>CARTELLONE</title>\n"
"<title>MACRO</title>\n"
"<title>VIAL AGRO</title>\n"
"<title>ISOLUX CORSÁN</title>\n"
"<title>AFCP</title>\n"
"<title>FINNING</title>\n"
"<title>ROGGIO</title>\n"
"<title>ROVELLA CARRANZA</title>\n"
"<title>ACINDAR</title>\n"
"<title>IERIC</title>\n"
"<title>IGARRETA MÁQUINAS</title>\n"
"<title>RIVA</title>\n"
"<title>GRUPO ESTISOL</title>\n"
"<title>IECSA</title>\n"
"<title>ARMAFERRO</title>\n"
"<title>BRICONS</title>\n"
"<title>CNH INDUSTRIAL</title>\n"
"<title>PAOLINI</title>\n"
"<title>SERVIUR</title>\n"
"<title>SANDVIK</title>\n"
"<title>DECAVIAL</title>\n"
"<title>ODEBRECHT</title>\n"
"<title>ENAS</title>\n"
"<title>SITRA</title>\n"
"<title>SUPERCEMENTO</title>\n"
"<title>JCR</title>\n"
"<title>CONSTRUMEX</title>\n"
"<title>BRIALES</title>\n"
"<title>CAPUTO</title>\n"
"<title>LUCIANO</title>\n"
"<title>GALICIA</title>\n"
"<title>VICTOR CONTRERAS</title>\n"
"<title>SIKA ARGENTINA</title>\n"
"<title>CRIBA</title>\n"
"<title>BOETTO Y BUTTIGLIENGO</title>\n"
"<title>MILICIC</title>\n"
"<title>PERIODICO EL CONSTRUCTOR</title>\n"
"<title>PHONERENTAL</title>\n"
"<title>DOS ARROYOS</title>\n"
"<title>MARTINEZ Y DE LA FUENTE</title>\n"
"<title>AUSA</title>\n"
"<title>LUIS LOSI</title>\n"
"<title>AESA</title>\n"
"<title>CONSTRUCTORA SUDAMERICANA</title>\n"
"<title>PLANTEL</title>\n"
"<title>PCR</title>\n"
"<title>BANCO DE LA NACIÓN ARGENTINA</title>\n"
"<title>SUBTERRÁNEOS DE BUENOS AIRES</title>\n"
"<title>HOLA SIM</title>\n"
"<title>JOSÉ LUIS TRIVIÑO</title>\n"
"<title>TECHINT</title>\n"
"<title>EDUARDO COLOMBI</title>\n"
"<title>ALEMARSA</title>\n"
"<title>CENTRO CONSTRUCCIONES</title>\n"
"<title>TECNIPISOS</title>\n"
"<title>XAPOR</title>\n"
"<title>FONTANA NICASTRO</title>\n"
"<title>CONCRET-NOR</title>\n"
"<title>DYCASA</title>\n"
"<title>BURGWARDT</title>\n"
"<title>SULLAIR</title>\n"
"<title>FONDO FIDUCIARIO FEDERAL DE INFRAESTRUCTURA REGIONAL</title>\n"
"<title>FLOWTEX</title>\n"
"<title>PETERSEN THIELE Y CRUZ</title>\n"
"<title>LIHUÉ</title>\n"
"<title>IRAM</title>\n"
"<title>ESTUDIO YMAZ</title>\n"
"<title>VIDOGAR</title>\n"
"<title>BICE</title>\n"
"<title>ROMERO CAMMISA</title>\n"
"<title>BATIMAT</title>\n"
"<title>ALBA CAUCIÓN</title>\n"
"<title>PROBA</title>\n"
"<title>ICF</title>\n"
"<title>TECMA</title>\n"
"<title>ALESTE</title>\n"
"<title>DELEGACIÓN PROVINCIA DE BUENOS AIRES</title>\n"
"<title>HIDRAVIAL</title>\n"
"<title>BANCO CIUDAD</title>\n"
"<title>LAMANNA</title>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.