using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z0-9]+(?:-[a-z0-9]+)*\.jpg$";
string input = @"test-file.jpg
test-123-test.jpg
123-456-thumbnail.jpg
test--123----.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}