// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z0-9]+(?:-[a-z0-9]+)*\.jpg$").unwrap();
let string = "test-file.jpg
test-123-test.jpg
123-456-thumbnail.jpg
test--123----.jpg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}