package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z0-9]+(?:-[a-z0-9]+)*\.jpg$`)
var str = `test-file.jpg
test-123-test.jpg
123-456-thumbnail.jpg
test--123----.jpg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}