re = /^[a-z0-9]+(?:-[a-z0-9]+)*\.jpg$/m
str = 'test-file.jpg
test-123-test.jpg
123-456-thumbnail.jpg
test--123----.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end