const regex = new RegExp('(?<!\\w)(?:(?:\\+91|0)\\s?)?\\d{10}\\b', 'gm')
const str = `+91 1234567890, 1234567790, 012345678900, 1234568901112
01234567890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}