import re
regex = re.compile(r"(?<!\w)(?:(?:\+91|0)\s?)?\d{10}\b", flags=re.MULTILINE)
test_str = ("+91 1234567890, 1234567790, 012345678900, 1234568901112\n"
"01234567890")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")