$re = '/(?<!\w)(?:(?:\+91|0)\s?)?\d{10}\b/m';
$str = '+91 1234567890, 1234567790, 012345678900, 1234568901112
01234567890';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);