re = /(?<!\w)(?:(?:\+91|0)\s?)?\d{10}\b/m
str = '+91 1234567890, 1234567790, 012345678900, 1234568901112
01234567890'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end