package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:^|\s)членс.*(июн|июл|авг|сент|окт|дек|янв|февр|мар|апр|май|мая).*?(\d{4})`)
var str = `Оплата по счету № 24260 от 25.06.2019г. Членские взносы июль 2019г. ИГК 1619187302962432209016045. Сумма 4000-00 Без налога (НДС)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}