// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:^|\s)членс.*(июн|июл|авг|сент|окт|дек|янв|февр|мар|апр|май|мая).*?(\d{4})").unwrap();
let string = "Оплата по счету № 24260 от 25.06.2019г. Членские взносы июль 2019г. ИГК 1619187302962432209016045. Сумма 4000-00 Без налога (НДС)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}