using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[@@]([^][\s#<>|{}]+)";
string input = @"Check out @Dreams_n_Songs and give them a follow! I can't recommend their hoodies enough!Shop now 👉…
.@ChelseaFC, @FCBayern, @VfL_Wolfsburg and more are among the latest names to be confirmed at -…";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}