$re = '/[@@]([^][\s#<>|{}]+)/m';
$str = 'Check out @Dreams_n_Songs and give them a follow! I can\'t recommend their hoodies enough!Shop now 👉…
.@ChelseaFC, @FCBayern, @VfL_Wolfsburg and more are among the latest names to be confirmed at -…';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);