re = /[@@]([^][\s#<>|{}]+)/m
str = 'Check out @Dreams_n_Songs and give them a follow! I can\'t recommend their hoodies enough!Shop now 👉…
.@ChelseaFC, @FCBayern, @VfL_Wolfsburg and more are among the latest names to be confirmed at -…'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end