import re
regex = re.compile(r"[@@]([^][\s#<>|{}]+)", flags=re.MULTILINE)
test_str = ("Check out @Dreams_n_Songs and give them a follow! I can't recommend their hoodies enough!Shop now 👉… \n"
".@ChelseaFC, @FCBayern, @VfL_Wolfsburg and more are among the latest names to be confirmed at -…")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")