const regex = /(?<countryCode>\+?82)?(?:[ -.]?|0?)(?<areaCode>1[01689])(?:[ -.]?)(?<firstFourDigits>\d{3,4})(?:[ -.]?)(?<lastFourDigits>\d{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<countryCode>\\+?82)?(?:[ -.]?|0?)(?<areaCode>1[01689])(?:[ -.]?)(?<firstFourDigits>\\d{3,4})(?:[ -.]?)(?<lastFourDigits>\\d{4})', 'gm')
const str = `+82(10)3341-6922
1063543808`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}