re = /(?<countryCode>\+?82)?(?:[ -.]?|0?)(?<areaCode>1[01689])(?:[ -.]?)(?<firstFourDigits>\d{3,4})(?:[ -.]?)(?<lastFourDigits>\d{4})/m
str = '+82(10)3341-6922
1063543808'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end