// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<countryCode>\+?82)?(?:[ -.]?|0?)(?<areaCode>1[01689])(?:[ -.]?)(?<firstFourDigits>\d{3,4})(?:[ -.]?)(?<lastFourDigits>\d{4})").unwrap();
let string = "+82(10)3341-6922
1063543808";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}