import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "(http|https):\\/\\/workdone\\.myxteam\\.com\\/project\\/([0-9]+)(\\/)?(kanban|user|table|calendar|gantt|dasboard)?$";
        final String string = "https://workdone.myxteam.com/project/5427/kanban\n"
	 + "https://workdone.myxteam.com/project/5427/table\n"
	 + "https://workdone.myxteam.com/project/\n"
	 + "https://workdone.myxteam.com/project/5427\n"
	 + "https://workdone.myxteam.com/project/5427/\n\n"
	 + "http://workdone.myxteam.com/project/5427/task/12715709";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}