use strict;
my $str = 'https://workdone.myxteam.com/project/5427/kanban
https://workdone.myxteam.com/project/5427/table
https://workdone.myxteam.com/project/
https://workdone.myxteam.com/project/5427
https://workdone.myxteam.com/project/5427/
http://workdone.myxteam.com/project/5427/task/12715709';
my $regex = qr/(http|https):\/\/workdone\.myxteam\.com\/project\/([0-9]+)(\/)?(kanban|user|table|calendar|gantt|dasboard)?$/mp;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}