import re
regex = re.compile(r"(http|https):\/\/workdone\.myxteam\.com\/project\/([0-9]+)(\/)?(kanban|user|table|calendar|gantt|dasboard)?$", flags=re.MULTILINE)
test_str = ("https://workdone.myxteam.com/project/5427/kanban\n"
"https://workdone.myxteam.com/project/5427/table\n"
"https://workdone.myxteam.com/project/\n"
"https://workdone.myxteam.com/project/5427\n"
"https://workdone.myxteam.com/project/5427/\n\n"
"http://workdone.myxteam.com/project/5427/task/12715709")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")