import Foundation
let pattern = #"(http|https):\/\/workdone\.myxteam\.com\/project\/([0-9]+)(\/)?(kanban|user|table|calendar|gantt|dasboard)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://workdone.myxteam.com/project/5427/kanban
https://workdone.myxteam.com/project/5427/table
https://workdone.myxteam.com/project/
https://workdone.myxteam.com/project/5427
https://workdone.myxteam.com/project/5427/
http://workdone.myxteam.com/project/5427/task/12715709
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)