#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\w+::\w+(?:\(\))?|\p{L}+(?:[-'_$]\p{L}+)*)(*SKIP)(*F)|[^\p{L}\s]"
Local $sString = "# Re-loading pkgdown while it's running causes weird behaviour with # the context cache don't" & @CRLF & _
"# Needs to handle NA for desc::desc_get()" & @CRLF & _
"# Update href of toc anchors , use "-" instead "."" & @CRLF & _
"# Keep something$col or here_you::must_stay"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)