$re = '/(?:\w+::\w+(?:\(\))?|\p{L}+(?:[-\'_$]\p{L}+)*)(*SKIP)(*F)|[^\p{L}\s]/m';
$str = '# Re-loading pkgdown while it\'s running causes weird behaviour with # the context cache don\'t
# Needs to handle NA for desc::desc_get()
# Update href of toc anchors , use "-" instead "."
# Keep something$col or here_you::must_stay';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;