import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\w+::\\w+(?:\\(\\))?|\\p{L}+(?:[-'_$]\\p{L}+)*)(*SKIP)(*F)|[^\\p{L}\\s]";
final String string = "# Re-loading pkgdown while it's running causes weird behaviour with # the context cache don't\n"
+ "# Needs to handle NA for desc::desc_get()\n"
+ "# Update href of toc anchors , use \"-\" instead \".\"\n"
+ "# Keep something$col or here_you::must_stay";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}