const regex = /(?:\w+::\w+(?:\(\))?|\p{L}+(?:[-'_$]\p{L}+)*)(*SKIP)(*F)|[^\p{L}\s]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\w+::\\w+(?:\\(\\))?|\\p{L}+(?:[-\'_$]\\p{L}+)*)(*SKIP)(*F)|[^\\p{L}\\s]', 'gm')
const str = `# Re-loading pkgdown while it's running causes weird behaviour with # the context cache don't
# Needs to handle NA for desc::desc_get()
# Update href of toc anchors , use "-" instead "."
# Keep something\$col or here_you::must_stay`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);