#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\b\w+(?:\s+\w+)*?)([\p{P}\s]*\1)+\b"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
" I, I, I am really wanting to go, but I I am not, am not am notty able to do it." & @CRLF & _
"" & @CRLF & _
"a b a b a b a b " & @CRLF & _
"" & @CRLF & _
"you, you*;!? .you"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)