$re = '/(\b\w+(?:\s+\w+)*?)([\p{P}\s]*\1)+\b/m';
$str = '
I, I, I am really wanting to go, but I I am not, am not am notty able to do it.
a b a b a b a b
you, you*;!? .you';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;