const regex = new RegExp('(\\b\\w+(?:\\s+\\w+)*?)([\\p{P}\\s]*\\1)+\\b', 'gm')
const str = `
I, I, I am really wanting to go, but I I am not, am not am notty able to do it.
a b a b a b a b
you, you*;!? .you`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);