using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b\w+(?:\s+\w+)*?)([\p{P}\s]*\1)+\b";
string substitution = @"$1";
string input = @"
I, I, I am really wanting to go, but I I am not, am not am notty able to do it.
a b a b a b a b
you, you*;!? .you";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}