#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(5[1-5][0-9]{2}[ -])([0-9]{4}[ -]){2}[0-9]{4}\b|\b(5[1-5][0-9]{2})([0-9]{4}){3}\b|\b222[1-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b222[1-9]([0-9]{4}){3}\b|\b22[3-9][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b22[3-9][0-9]([0-9]{4}){3}\b|\b2[3-6][0-9]{2}[ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b2[3-6][0-9]{2}([0-9]{4}){3}\b|\b27[01][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b27[01][0-9]([0-9]{4}){3}\b|\b2720[ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b2720([0-9]{4}){3}\b"
Local $sString = "MasterCard:" & @CRLF & _
"Requirements: MasterCard numbers either start with the numbers 51 through 55 or with the numbers 2221 through 2720. All have 16 digits." & @CRLF & _
"" & @CRLF & _
"Pattern Parts:" & @CRLF & _
"Starts with numbers 51 through 55:" & @CRLF & _
"1) \b(5[1-5][0-9]{2}[ -])([0-9]{4}[ -]){2}[0-9]{4}\b|\b(5[1-5][0-9]{2})([0-9]{4}){3}\b" & @CRLF & _
"" & @CRLF & _
"Starts with numbers 2221 through 2720:" & @CRLF & _
"2) \b222[1-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b222[1-9]([0-9]{4}){3}\b" & @CRLF & _
"3) \b22[3-9][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b22[3-9][0-9]([0-9]{4}){3}\b" & @CRLF & _
"4) \b2[3-6][0-9]{2}[ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b2[3-6][0-9]{2}([0-9]{4}){3}\b" & @CRLF & _
"5) \b27[01][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b27[01][0-9]([0-9]{4}){3}\b" & @CRLF & _
"6) \b2720[ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b2720([0-9]{4}){3}\b" & @CRLF & _
"" & @CRLF & _
"Combining 1-6 to form one pattern:" & @CRLF & _
"\b(5[1-5][0-9]{2}[ -])([0-9]{4}[ -]){2}[0-9]{4}\b|\b(5[1-5][0-9]{2})([0-9]{4}){3}\b|\b222[1-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b222[1-9]([0-9]{4}){3}\b|\b22[3-9][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b22[3-9][0-9]([0-9]{4}){3}\b|\b2[3-6][0-9]{2}[ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b2[3-6][0-9]{2}([0-9]{4}){3}\b|\b27[01][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b27[01][0-9]([0-9]{4}){3}\b|\b2720[ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b2720([0-9]{4}){3}\b" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Test Cases:" & @CRLF & _
"Should fire:" & @CRLF & _
"16 length, no space, start with 51-55 5123123412341234" & @CRLF & _
"16 length, dashes, start with 51-55 5123-1234-1234-1234" & @CRLF & _
"16 length, spaces, start with 51-55 5123 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"16 length, no space, start with 2221-2720 2221123412341234" & @CRLF & _
"16 length, dashes, start with 2221-2720 2221-1234-1234-1234" & @CRLF & _
"16 length, spaces, start with 2221-2720 2221 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"16 length, no space, start with 2221-2720 2241123412341234" & @CRLF & _
"16 length, dashes, start with 2221-2720 2241-1234-1234-1234" & @CRLF & _
"16 length, spaces, start with 2221-2720 2241 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"16 length, no space, start with 2221-2720 2321123412341234" & @CRLF & _
"16 length, dashes, start with 2221-2720 2321-1234-1234-1234" & @CRLF & _
"16 length, spaces, start with 2221-2720 2321 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"16 length, no space, start with 2221-2720 2705123412341234" & @CRLF & _
"16 length, dashes, start with 2221-2720 2705-1234-1234-1234" & @CRLF & _
"16 length, spaces, start with 2221-2720 2705 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"16 length, no space, start with 2221-2720 2720123412341234" & @CRLF & _
"16 length, dashes, start with 2221-2720 2720-1234-1234-1234" & @CRLF & _
"16 length, spaces, start with 2221-2720 2720 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"Should not fire:" & @CRLF & _
"16 length, no space, not start with 51-55 5623123412341234" & @CRLF & _
"16 length, dashes, not start with 51-55 5623-1234-1234-1234" & @CRLF & _
"16 length, spaces, not start with 51-55 5623 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"16 length, no space, not start with 2221-2720 2220123412341234" & @CRLF & _
"16 length, dashes, not start with 2221-2720 2220-1234-1234-1234" & @CRLF & _
"16 length, spaces, not start with 2221-2720 2220 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"Non 16 length, matches 51 pattern start 5123-1234-1234-123" & @CRLF & _
"Non 16 length, matches 2221 pattern start 2221-1234-1234-123" & @CRLF & _
"" & @CRLF & _
"Malformed, matches 51 pattern start 51-2312-34-1234-1234 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")