const regex = /\b(5[1-5][0-9]{2}[ -])([0-9]{4}[ -]){2}[0-9]{4}\b|\b(5[1-5][0-9]{2})([0-9]{4}){3}\b|\b222[1-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b222[1-9]([0-9]{4}){3}\b|\b22[3-9][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b22[3-9][0-9]([0-9]{4}){3}\b|\b2[3-6][0-9]{2}[ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b2[3-6][0-9]{2}([0-9]{4}){3}\b|\b27[01][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b27[01][0-9]([0-9]{4}){3}\b|\b2720[ -]([0-9]{4}[ -]){2}[0-9]{4}\b|\b2720([0-9]{4}){3}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(5[1-5][0-9]{2}[ -])([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b(5[1-5][0-9]{2})([0-9]{4}){3}\\b|\\b222[1-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b222[1-9]([0-9]{4}){3}\\b|\\b22[3-9][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b22[3-9][0-9]([0-9]{4}){3}\\b|\\b2[3-6][0-9]{2}[ -]([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b2[3-6][0-9]{2}([0-9]{4}){3}\\b|\\b27[01][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b27[01][0-9]([0-9]{4}){3}\\b|\\b2720[ -]([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b2720([0-9]{4}){3}\\b', 'gm')
const str = `MasterCard:
Requirements: MasterCard numbers either start with the numbers 51 through 55 or with the numbers 2221 through 2720. All have 16 digits.
Pattern Parts:
Starts with numbers 51 through 55:
1) \\b(5[1-5][0-9]{2}[ -])([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b(5[1-5][0-9]{2})([0-9]{4}){3}\\b
Starts with numbers 2221 through 2720:
2) \\b222[1-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b222[1-9]([0-9]{4}){3}\\b
3) \\b22[3-9][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b22[3-9][0-9]([0-9]{4}){3}\\b
4) \\b2[3-6][0-9]{2}[ -]([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b2[3-6][0-9]{2}([0-9]{4}){3}\\b
5) \\b27[01][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b27[01][0-9]([0-9]{4}){3}\\b
6) \\b2720[ -]([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b2720([0-9]{4}){3}\\b
Combining 1-6 to form one pattern:
\\b(5[1-5][0-9]{2}[ -])([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b(5[1-5][0-9]{2})([0-9]{4}){3}\\b|\\b222[1-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b222[1-9]([0-9]{4}){3}\\b|\\b22[3-9][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b22[3-9][0-9]([0-9]{4}){3}\\b|\\b2[3-6][0-9]{2}[ -]([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b2[3-6][0-9]{2}([0-9]{4}){3}\\b|\\b27[01][0-9][ -]([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b27[01][0-9]([0-9]{4}){3}\\b|\\b2720[ -]([0-9]{4}[ -]){2}[0-9]{4}\\b|\\b2720([0-9]{4}){3}\\b
Test Cases:
Should fire:
16 length, no space, start with 51-55 5123123412341234
16 length, dashes, start with 51-55 5123-1234-1234-1234
16 length, spaces, start with 51-55 5123 1234 1234 1234
16 length, no space, start with 2221-2720 2221123412341234
16 length, dashes, start with 2221-2720 2221-1234-1234-1234
16 length, spaces, start with 2221-2720 2221 1234 1234 1234
16 length, no space, start with 2221-2720 2241123412341234
16 length, dashes, start with 2221-2720 2241-1234-1234-1234
16 length, spaces, start with 2221-2720 2241 1234 1234 1234
16 length, no space, start with 2221-2720 2321123412341234
16 length, dashes, start with 2221-2720 2321-1234-1234-1234
16 length, spaces, start with 2221-2720 2321 1234 1234 1234
16 length, no space, start with 2221-2720 2705123412341234
16 length, dashes, start with 2221-2720 2705-1234-1234-1234
16 length, spaces, start with 2221-2720 2705 1234 1234 1234
16 length, no space, start with 2221-2720 2720123412341234
16 length, dashes, start with 2221-2720 2720-1234-1234-1234
16 length, spaces, start with 2221-2720 2720 1234 1234 1234
Should not fire:
16 length, no space, not start with 51-55 5623123412341234
16 length, dashes, not start with 51-55 5623-1234-1234-1234
16 length, spaces, not start with 51-55 5623 1234 1234 1234
16 length, no space, not start with 2221-2720 2220123412341234
16 length, dashes, not start with 2221-2720 2220-1234-1234-1234
16 length, spaces, not start with 2221-2720 2220 1234 1234 1234
Non 16 length, matches 51 pattern start 5123-1234-1234-123
Non 16 length, matches 2221 pattern start 2221-1234-1234-123
Malformed, matches 51 pattern start 51-2312-34-1234-1234
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}