use strict;
my $str = 'something(name_one,name_two).';
my $regex = qr/\((.+),(.+)\)/mp;
my $subst = '(\\2,\\1)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";