re = /\((.+),(.+)\)/m
str = 'something(name_one,name_two).'
subst = '(\\2,\\1)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result