$re = '/\((.+),(.+)\)/m';
$str = 'something(name_one,name_two).';
$subst = "(\2,\1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;